システム開発・構築の神様

新しいサービスや技術を使った開発や構築。その他不具合解決など

最新版PHP7.3.1にするとエラーログに警告が表示されるようになった

2018年12月末にPHP7.3が正式リリースされました。7.2よりさらに高速になっているという話もあるので

 

早速インストールしてみると・・・

 

何やら良くわからないエラーが出力されるようになりました。

 

Severity: Warning --> "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2

 

まあ、読んで字のごとく・・・

 

switch文の分岐で、breakの中にcontinueがありまっせ!って感じでしょうか?

 

switch文上のforやforeachなどのcontinueにも関わらず、switch文のcontinueと見られているバグ?

 

ネット上では、不具合として考えられているようです。

 

ので、修正版がでるまで警告を無視するか?最新版へのアップデートを控えたほうが良さそうですね。

 

肝心の速度は、体感的によく分かりませんでした。。。